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Computer Network 
 

Definitions: 

• Data Communications:  

o This is the transfer of data between devices. It's the process of sending 

and receiving information electronically. 

• Computer Network:  

o A computer network is a collection of interconnected devices that can 

communicate and share resources. 

 

Advantages of Networking Computers: 

1. Resource Sharing:  

o Networks allow multiple users to share hardware devices like printers, 

scanners, and storage devices, reducing costs. 

2. Data and Information Sharing:  

o Networks enable easy access to and sharing of files and data among 

authorized users, improving collaboration and productivity. 

3. Enhanced Communication:  

o Networks facilitate communication through email, instant messaging, 

video conferencing, and other tools, enabling efficient information 

exchange. 

4. Centralized Data Management:  

o Networks allow for centralized storage and management of data, 

making it easier to back up, secure, and update information. 
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5. Increased Productivity:  

o By enabling resource and information sharing, networks streamline 

workflows and improve overall productivity. 

6. Software and Application Sharing:  

o Networks allow for the sharing of software applications, reducing the 

need to install software on individual computers. 

 

Disadvantages of Networking Computers: 

1. Security Risks:  

o Networks are vulnerable to security threats such as viruses, malware, 

and unauthorized access, which can compromise sensitive data. 

2. Network Downtime:  

o Network failures can disrupt communication and access to resources, 

leading to downtime and lost productivity. 

3. Complexity and Maintenance:  

o Setting up and maintaining a network can be complex and require 

skilled personnel, leading to increased costs. 

4. Dependency on the Server:  

o In client-server networks, if the server fails, the entire network may be 

affected. 

5. Cost:  

o The initial setup cost of network hardware and software can be high. 

Also the cost of ongoing maintenance. 

6. Potential for Data Loss:  

o If proper backup procedures are not in place, network failures or 

security breaches can lead to data loss. 

  



Types of Networks  

(Think of it like different sizes of neighbourhoods): 

• LAN (Local Area Network):  

o Imagine your house or a small office. That is a LAN. It is a network that 

covers a small geographical area. 

o It connects devices like computers, printers, and smartphones within 

that limited space. 

o LANs are typically fast and relatively inexpensive to set up. 

o Example: Your home Wi-Fi network. 

• MAN (Metropolitan Area Network):  

o Now, think of a whole city. That is a MAN. It is larger than a LAN but 

smaller than a WAN. 

o It connects networks within a city or metropolitan area. 

o MANs are often used by organizations that have multiple offices in a 

city. 

o Example: A city wide network used by a university, or a large company 

that has many buildings in a city. 

• WAN (Wide Area Network):  

o Finally, imagine the entire world. That is a WAN. It is the largest type of 

network. 

o It connects networks across large geographical distances, like 

countries or continents. 

o The internet is the biggest example of a WAN. 

o WANs are slower than LANs and MANs because data has to travel 

much farther. 

 

 

 



Network Topologies  

(Think of it like how the roads in your neighborhood are laid out): 

• Bus Topology:  

o Imagine a single straight road with houses (computers) connected to it. 

o All devices are connected to a single cable called a "bus." 

o Data travels along the bus, and every device sees it. 

o If the bus cable breaks, the entire network goes down. 

o This is an older style of network and is not very common anymore. 

 

 

• Ring Topology:  

o Imagine a circular road with houses (computers) connected to it. 

o Each device is connected to two other devices, forming a closed loop. 

o Data travels in one direction around the ring. 

o If one device or cable fails, the entire network can be affected. 

o Also, an older style of network, and not very common anymore. 

 

 



• Star Topology:  

o Imagine a central hub or switch (like a town square) with roads (cables) 

leading to each house (computer). 

o All devices are connected to the central hub. 

o Data travels through the hub to the destination device. 

o If a device or cable fails, only that device is affected. 

o If the central hub fails the whole network fails. 

o This is a very common topology in modern networks. 

 

 

 

• Mesh Topology:  

o Imagine a neighbourhood where every house (computer) has its own 

road (cable) to every other house. 

o Each device is connected to many other devices. 

o Data can travel along multiple paths. 

o This is very reliable because if one path fails, data can still travel along 

another path. 

o This topology is very expensive to implement. 

o This topology is used where high reliability is needed. 



 

 

 

 

 

Client-server setup and the network devices that make it work 

Client-Server Setup: 

Imagine a restaurant: 

• Server: This is like the kitchen and the head chef. It's a powerful computer 

that stores and manages data, applications, and resources. It provides 

services to other computers on the network.  

o In a business, servers might handle:  

▪ File storage (company documents). 

▪ Email. 

▪ Website hosting. 

▪ Database management (customer information). 

▪ Application hosting (accounting software). 

• Client: This is like the dining area and the customers. These are the 

workstations (computers) that employees use. They request services from the 

server.  

o Clients might:  



▪ Access shared files on the server. 

▪ Send and receive emails through the server. 

▪ Access company applications hosted on the server. 

▪ browse the internet. 

• The Process:  

o A client sends a request to the server. 

o The server processes the request. 

o The server sends a response back to the client. 

 

 

 

Common Network Devices: 

 

• Server:  

o As explained above, the powerful computer that provides services. 

• Client:  

o The workstations that users interact with. 

• Router:  

o Think of a router as a traffic director. It connects different networks 

together, like your local network to the internet. 

o It determines the best path for data to travel. 

• Switch:  

o A switch connects devices within a local network (LAN). 

o It intelligently forwards data to the correct destination device. 

o Switches operate at layer 2 of the OSI model, using MAC addresses. 

• Hub:  



o An older and less efficient device. A hub also connects devices in a 

LAN, but it simply broadcasts data to all connected devices. 

o Hubs operate at layer 1 of the OSI model. 

o This can lead to network congestion and security issues. 

o Hubs are rarely used in modern networks. 

• Bridge:  

o A bridge connects two LAN segments, filtering traffic based on MAC 

addresses. 

o Bridges operate at layer 2 of the OSI model. 

o They are used to segment networks and improve performance. 

 

 

. 

Wi-Fi and Hotspots as Network Distribution Resources: 

• Wi-Fi (Wireless Fidelity): 

o Wi-Fi is a wireless networking technology that uses radio waves to 

provide internet access and network connectivity. 

o It allows devices like laptops, smartphones, and tablets to connect to a 

network without physical cables. 

o How it Works:  

▪ A wireless router broadcasts a Wi-Fi signal. 

▪ Devices with Wi-Fi adapters can detect and connect to this 

signal. 

▪ The router connects to a wired network (like your internet 

service provider) and acts as a bridge between the wireless 

devices and the internet. 

o Wi-Fi as a Distribution Resource:  



▪ It provides convenient and flexible network access, especially in 

homes, offices, and public spaces. 

▪ It eliminates the need for cumbersome cables, making it easy to 

connect multiple devices. 

▪ It allows for mobility within the coverage area. 

• Hotspot: 

o A hotspot is a location where Wi-Fi internet access is made available. 

o It can be provided by:  

▪ A dedicated Wi-Fi router in a public place (like a coffee shop or 

airport). 

▪ A smartphone or mobile device that shares its cellular data 

connection (mobile hotspot). 

o Hotspot as a Distribution Resource:  

▪ It provides internet access to users on the go. 

▪ It is useful for travellers, remote workers, and anyone who 

needs temporary internet access. 

▪ Mobile hotspots allow for connectivity in areas where normal Wi-

Fi is not available. 

 

 

Evaluating Network Environments: Intranet and Extranet for 

Business: 

• Intranet:  

o An intranet is a private network that is accessible only to authorized 

users within an organization. 

o It's like a company's internal website. 

o Business Evaluation:  

▪ Advantages:  



▪ Improved Communication: Facilitates internal 

communication and collaboration. 

▪ Enhanced Information Sharing: Provides a central 

repository for company documents and resources. 

▪ Increased Productivity: Streamlines workflows and 

improves access to information. 

▪ Enhanced Security: Limits access to sensitive 

information. 

▪ Disadvantages:  

▪ Maintenance Costs: Requires ongoing maintenance and 

updates. 

▪ Security Risks: Vulnerable to internal security threats. 

▪ Limited Accessibility: Only accessible to authorized 

users within the organization. 

 

• Extranet:  

o An extranet is a controlled network that allows authorized external 

users (like customers, suppliers, or partners) to access specific parts of 

an organization's intranet. 

o It's like a bridge between the company's internal network and selected 

external parties. 

o Business Evaluation:  

▪ Advantages:  

▪ Improved Collaboration: Facilitates collaboration with 

external partners. 

▪ Enhanced Customer Service: Provides customers with 

access to order tracking, support, and other services. 

▪ Streamlined Supply Chain Management: Enables 

efficient communication and data exchange with 

suppliers. 

▪ Increased Efficiency: Automates business processes 

and reduces manual data entry. 



▪ Disadvantages:  

▪ Security Risks: Increases the risk of unauthorized 

access to sensitive information. 

▪ Complexity: Requires careful planning and 

implementation to ensure security and control. 

▪ Dependancy: Dependancy on outside vendors to 

maintain network integrity. 

 

 

The Internet and Its Uses: 

• Definition:  

o The internet is a global network of interconnected computer networks 

that use the internet protocol suite (TCP/IP) to transmit data. It's 

essentially a vast system that links billions of devices worldwide. 

• Uses:  

o Communication: Email, instant messaging, video conferencing, social 

media. 

o Information Access: Searching for information, online encyclopedias, 

news websites. 

o E-commerce: Online shopping, online banking, digital marketplaces. 

o Entertainment: Streaming music and videos, online gaming, social 

media. 

o Education: Online courses, research, virtual learning environments. 

o Business: Online marketing, remote work, cloud computing. 

 

 

Advantages and Disadvantages of the Internet: 

• Advantages:  

o Global Communication: Connects people worldwide instantly. 

o Access to Information: Provides a vast repository of knowledge. 

o Enhanced Communication: allows for many forms of communication. 



o E-commerce and Online Business: Facilitates online transactions 

and business operations. 

o Remote Work and Collaboration: Enables flexible work 

arrangements. 

o Educational Resources: Offers a wide range of learning 

opportunities. 

 

• Disadvantages:  

o Security Risks: Vulnerability to cyberattacks, malware, and data 

breaches. 

o Misinformation and Fake News: Spread of inaccurate or misleading 

information. 

o Privacy Concerns: Collection and misuse of personal data. 

o Internet Addiction: Excessive internet use can lead to negative 

consequences. 

o Cybercrime: Online fraud, identity theft, and other criminal activities. 

o Social Isolation: Excessive online interaction can sometimes lead to 

decreased real world social interactions. 

 

 

Requirements for Corporate Internet Connectivity: 

To establish a robust internet connection for a corporation, the following hardware 

and software are essential: 

• Hardware:  

o High-Speed Internet Connection:  

▪ Fiber-optic, cable, or dedicated internet access (DIA) lines. 

o Router:  

▪ A business-grade router to manage network traffic and security. 

o Firewall:  

▪ Hardware or software firewall to protect the network from 

unauthorized access. 



o Switches:  

▪ To connect multiple devices within the local network. 

o Modem:  

▪ To translate the internet signal from the internet service 

provider. 

o Wi-Fi Access Points:  

▪ For wireless connectivity throughout the office. 

o Servers:  

▪ For web hosting, email, and other online services. 

o Backup Power Supply (UPS):  

▪ To ensure uninterrupted internet access during power outages. 

 

• Software:  

o Firewall Software:  

▪ To supplement hardware firewalls and provide advanced 

security features. 

o Antivirus and Anti-malware Software:  

▪ To protect devices from online threats. 

o VPN (Virtual Private Network):  

▪ For secure remote access to the corporate network. 

o Network Monitoring Software:  

▪ To track network performance and identify potential issues. 

o Web Filtering Software:  

▪ To control access to specific websites and content. 

o Email Security Software:  

▪ To protect against spam and phishing attacks. 



o Operating systems:  

▪ Up to date operating systems on all computers. 

 

Web Browsers and Internet Addresses (URLs): 

• Web Browser:  

o Think of a web browser as a window to the internet. It's a software 

application that allows you to access and view websites. 

o Examples: Google Chrome, Mozilla Firefox, Safari, Microsoft Edge. 

o Function:  

▪ It interprets the code (HTML) that websites are written in and 

displays it in a user-friendly way. 

▪ It allows you to navigate between web pages by clicking on 

links. 

▪ It handles the communication between your computer and the 

web server that hosts the website. 

 

• Internet Addresses (URLs - Uniform Resource Locators):  

o A URL is like the address of a house on the internet. It tells your 

browser where to find a specific web page. 

o Structure:  

▪ https://www.example.com/page.html  

▪ https:// (Protocol): This indicates the communication 

protocol used (HTTPS is secure). 

▪ www.example.com (Domain Name): This is the human-

readable name of the website. 

▪ /page.html (Path): This specifies the location of a 

specific page within the website. 

o Knowing the URL allows you to directly travel to a specific webpage. 

 



Searching Information on the Internet: 

1. Open a Web Browser:  

o Launch your preferred web browser (e.g., Chrome, Firefox). 

2. Use a Search Engine:  

o The most common way to find information is to use a search engine 

like Google, Bing, or DuckDuckGo. 

o Type the search engine's URL into the address bar (e.g., 

www.google.com). 

3. Enter Search Terms:  

o In the search bar, type the keywords or phrases that describe what 

you're looking for. 

o Be specific to get more relevant results. 

4. Review Search Results:  

o The search engine will display a list of web pages that it considers 

relevant to your search terms. 

o Read the titles and descriptions to find pages that seem promising. 

5. Click on Links:  

o Click on the links to the web pages that you want to visit. 

6. Refine Your Search:  

o If you don't find what you're looking for, try using different keywords or 

phrases. 

o use advanced search options. Most search engines have them. 

 

Browser Functions to Surf the Internet: 

• Address Bar:  

o Where you type URLs to visit websites. 

• Back and Forward Buttons:  

o To navigate through your browsing history. 



• Refresh/Reload Button:  

o To reload the current web page. 

• Tabs:  

o To open multiple web pages in a single browser window. 

• History:  

o To view a list of websites you've visited. 

• Settings:  

o To customize your browser's appearance and behavior. 

• Incognito/Private Browsing:  

o Browsing mode that does not save your browsing history or cookies. 

 

 

Creating and Organizing a List of Favorites/Bookmarks: 

• Bookmarks/Favorites:  

o These are shortcuts to websites that you want to save for easy access. 

• How to Create a Bookmark:  

o Visit the Website: Go to the web page you want to save. 

o Click the Bookmark/Star Icon: Look for a star or bookmark icon in the 

address bar or browser menu. 

o Save the Bookmark: Choose a name for the bookmark and select a 

folder to save it in. 

• Organizing Bookmarks:  

o Create Folders: Create folders to categorize your bookmarks (e.g., 

"Work," "News," "Recipes"). 

o Drag and Drop: Drag and drop bookmarks into folders to organize 

them. 

o Bookmark Managers: Some browsers have built in bookmark 

managers to help organize very large amounts of bookmarks. 



o Bookmark Bars: Most browsers have a bookmark bar that is located 

right below the address bar. This bar is for frequently used bookmarks. 

 

 

 

 

Protecting Your Privacy Online: 

The internet offers vast information, but it is crucial to protect your personal data. 

Here are key measures: 

1. Use Strong, Unique Passwords:  

o Create complex passwords with a mix of uppercase and lowercase 

letters, numbers, and symbols. 

o Avoid using easily guessable information like birthdays or names.1 

o Use a different password for each online account. 

o Consider using a password manager to generate and store secure 

passwords. 

2. Enable Two-Factor Authentication (2FA):  

o 2FA adds an extra layer of security by requiring a second form of 

verification (e.g., a code from your phone) in addition to your password. 

o Enable 2FA whenever possible. 

3. Be Cautious of Phishing Scams:  

o Phishing emails and websites attempt to trick you into revealing 

personal information. 

o Be wary of suspicious emails or links, especially those asking for 

sensitive data. 

o Verify the sender's address and the website's URL before providing 

any information. 

4. Control Your Social Media Privacy:  



o Review your privacy settings on social media platforms and limit the 

information you share publicly. 

o Be mindful of what you post and who can see it. 

o Avoid sharing personal details like your address, phone number, or 

financial information. 

5. Use a Virtual Private Network (VPN):  

o A VPN encrypts your internet traffic and hides your IP address, making 

it more difficult for others to track your online activity. 

o Use a reputable VPN service, especially when using public Wi-Fi. 

6. Keep Your Software Updated:  

o Regularly update your operating system, web browser, and antivirus 

software to patch security vulnerabilities. 

7. Clear Your Browsing History and Cookies:  

o Browsers store information about your online activity, including 

browsing history and cookies. 

o Periodically clear this data to reduce the amount of information that 

websites can collect about you. 

8. Be Mindful of Website Permissions:  

o Websites often request permission to access your location, camera, or 

microphone. 

o Grant permissions only to trusted websites and apps. 

9. Read Privacy Policies:  

o Before providing personal information to a website or app, read its 

privacy policy to understand how your data will be used. 

10. Use Secure Browsing (HTTPS):  

o Always check that the website URL begins with "HTTPS" (not "HTTP"). 

The "S" signifies that the connection is encrypted. 

 



Identifying and Selecting Communication Tools: 

Choosing the right communication tool depends on the type of communication you 

need. Here is a breakdown: 

• Email:  

o Purpose: Asynchronous communication, formal communication, 

sending documents or files. 

o When to Use: For detailed messages, official correspondence, or when 

a record of the communication is needed. 

• Instant Messaging (IM):  

o Purpose: Real-time text-based communication, quick exchanges, 

informal conversations. 

o When to Use: For quick questions, coordinating tasks, or casual chats. 

• Video Conferencing:  

o Purpose: Real-time audio and video communication, virtual meetings, 

presentations. 

o When to Use: For remote meetings, face-to-face interactions, or when 

visual communication is important. 

• Voice over IP (VoIP):  

o Purpose: Voice communication over the internet, phone calls. 

o When to use: For low cost phone calls, or when integrating phone 

systems with computer networks. 

• Social Media:  

o Purpose: Sharing information, connecting with others, building 

communities. 

o When to Use: For public announcements, social interactions, or 

marketing purposes. 

• Collaboration Platforms (e.g., Slack, Microsoft Teams):  

o Purpose: Team communication, file sharing, project management. 

o When to use: For group projects, team coordination, or centralizing 

team communication. 

• File Sharing Services (e.g., Google Drive, Dropbox):  

o Purpose: Sharing and collaborating on documents and files. 



o When to use: For collaborative projects, sharing large files, or backing 

up important data. 

• Online Forums/Discussion Boards:  

o Purpose: Asynchronous discussions on specific topics, knowledge 

sharing. 

o When to use: For technical support, community discussions, or sharing 

information on niche topics. 

 

 

Creating an Email Address with Data Protection Best Practices: 

1. Minimize Personal Information:  

o Avoid including your full name, birthdate, or other sensitive information 

in your email address. 

o Instead, consider using a combination of initials, numbers, or a 

pseudonym. 

2. Use a Reputable Email Provider:  

o Choose an email provider with a strong track record of privacy and 

security. 

o Look for providers that offer:  

▪ End-to-end encryption. 

▪ Two-factor authentication (2FA). 

▪ Clear and transparent privacy policies. 

▪ Options for data deletion. 

o Examples: ProtonMail, Tutanota, or even a well secured Gmail or 

Outlook account. 

3. Create Separate Email Addresses:  

o Use different email addresses for different purposes:  

▪ Personal communications. 



▪ Work-related emails. 

▪ Online shopping and subscriptions. 

▪ Sensitive transactions (e.g., banking). 

o This helps to limit the amount of information associated with each 

address. 

4. Avoid Publicly Sharing Your Primary Email:  

o Be cautious about posting your primary email address on public forums 

or social media. 

o Use a disposable email address for online forms or services that you 

don't fully trust. 

5. Review Privacy Settings:  

o Configure your email account's privacy settings to limit data collection 

and tracking. 

6. Use a Strong Password:  

o As always, create a strong, unique password for your email account. 

 

 

Adopting Safe Behaviour When Managing Unwanted Emails and 

Phishing: 

1. Don't Click on Suspicious Links:  

o Avoid clicking on links in emails from unknown senders or that seem 

suspicious. 

o Hover over links to see the actual URL before clicking. 

o If you're unsure, type the website's address directly into your browser. 

2. Don't Open Attachments from Unknown Senders:  

o Attachments can contain malware or viruses. 

o Only open attachments from trusted sources. 

3. Be Wary of Urgent or Threatening Emails:  



o Phishing emails often create a sense of urgency or fear to trick you into 

acting quickly. 

o Take a moment to evaluate the email before responding. 

4. Verify Sender Information:  

o Check the sender's email address carefully. 

o Look for misspellings or unusual characters. 

o If you're unsure, contact the sender through a known and trusted 

method (e.g., phone). 

5. Don't Provide Personal Information:  

o Legitimate organizations will rarely ask for sensitive information (e.g., 

passwords, credit card numbers) via email. 

6. Use Spam Filters:  

o Enable and configure your email provider's spam filters. 

o Mark suspicious emails as spam. 

7. Report Phishing:  

o Report phishing emails to your email provider and to the appropriate 

authorities. 

8. Keep Antivirus Software Updated:  

o Make sure your antivirus software is up-to-date to protect against 

malware. 

 

Sending Email Messages in an Adequate and Responsible 

Manner: 

1. Use a Clear and Concise Subject Line:  

o The subject line should accurately reflect the content of the email. 

2. Address the Recipient Appropriately:  

o Use the recipient's name and title (if applicable). 



3. Keep Your Message Brief and to the Point:  

o Avoid unnecessary details or rambling. 

4. Use Proper Grammar and Spelling:  

o Proofread your email before sending it. 

5. Be Professional and Courteous:  

o Use a professional tone and avoid offensive language. 

6. Include a Signature:  

o Add a signature with your name, contact information, and any relevant 

details. 

7. Use the "Reply All" Function Sparingly:  

o Only use "Reply All" when your response is relevant to everyone in the 

conversation. 

8. Be Mindful of Attachments:  

o Compress large files before sending them. 

o Clearly label attachments. 

9. Respect Privacy:  

o Avoid forwarding emails without the sender's permission. 

o Be cautious about sharing sensitive information via email. 

10. Consider the Tone:  

o Email can be easily misconstrued. read your email back to yourself 

before sending it to ensure that your tone is correct. 

 

 

 

 



Using "To," "Cc," and "Bcc" Adequately: 

• "To" Field:  

o This field is for the primary recipient(s) of the email. 

o These are the people who are expected to take action or respond to 

the email. 

o Use this field for the main person or people you want to directly 

address. 

• "Cc" (Carbon Copy) Field:  

o "Cc" is for people who need to be informed of the email's content but 

are not necessarily expected to take action. 

o It's a way to keep others in the loop. 

o Everyone in the "To" and "Cc" fields can see all the email addresses 

listed. 

o Example: You are emailing your manager, and cc a coworker that 

needs to be aware of the information. 

• "Bcc" (Blind Carbon Copy) Field:  

o "Bcc" is for people who need to receive a copy of the email, but you 

don't want the other recipients to know they received it. 

o It's used for privacy and to avoid revealing email addresses to a large 

group. 

o Recipients in the "To" and "Cc" fields cannot see the email addresses 

in the "Bcc" field. 

o Example: You are sending out a mass email, and want to protect the 

recipients privacy. 

 

 

 

 

 



Attaching Documents to an Email: 

1. Compose Your Email:  

o Write your email message as usual. 

2. Locate the "Attach" Button:  

o Most email clients have an "Attach" button or paperclip icon. 

3. Select the File(s):  

o Browse your computer or storage device to find the file(s) you want to 

attach. 

o Select the file(s) and click "Open" or "Attach." 

4. Verify the Attachment(s):  

o Ensure the correct file(s) are attached and that the file size is within the 

email provider's limits. 

5. Send the Email:  

o Once you're satisfied, send the email. 

 

 

Opening Attachments Safely and Saving Them: 

1. Scan for Viruses:  

o Before opening any attachment, especially from an unknown sender, 

scan it with your antivirus software. 

2. Be Cautious of File Types:  

o Be particularly cautious of executable files (.exe), script files (.vbs), and 

macro-enabled documents (.docm). These file types can pose a higher 

security risk. 

3. Preview Attachments (If Possible):  

o Some email clients allow you to preview attachments before opening 

them. Use this feature to get a quick glimpse of the content. 

4. Save Attachments to a Safe Location:  



o Instead of opening attachments directly from the email, save them to a 

safe location on your computer or storage device. 

o Create a dedicated folder for downloaded attachments. 

5. Save to Another Storage Device or Cloud Storage:  

o For important attachments, consider saving a copy to an external hard 

drive, USB drive, or cloud storage service. 

o This provides an extra layer of backup in case your computer 

experiences a problem. 

6. Rename Files Appropriately:  

o Rename downloaded files so that they are easily identified. 

7. Keep Software Updated:  

o Make sure that your operating system, and any programs that open 

attachments, are up to date. This will patch any known security 

vulnerabilities. 

 

 

Creating and Organizing a Contact List with Groups: 

1. Choose a Tool: 

o Email Client (e.g., Gmail, Outlook): Most email clients have built-in 

contact management features that allow you to create contact lists and 

groups (often called "distribution lists" or "contact groups"). 

o Contact Management Software (CRM): If you need more advanced 

features, consider using a CRM (Customer Relationship Management) 

system. These systems offer robust contact management, including 

grouping, tagging, and tracking interactions. 

o Spreadsheet (e.g., Excel, Google Sheets): For basic contact 

management, you can use a spreadsheet to create a list of contacts 

and add a column for group assignments. 



o Python: As demonstrated in the previous response, you can create a 

python script that will store contact information, and organize those 

contacts into groups. 

2. Add Contacts: 

o Enter the contact's name, email address, and any other relevant 

information (e.g., phone number, company, address). 

3. Create Groups: 

o Create groups based on your needs (e.g., "Clients," "Suppliers," "Team 

Members," "Friends"). 

o Give each group a descriptive name. 

4. Assign Contacts to Groups: 

o Add each contact to the appropriate group(s). 

o A contact can belong to multiple groups. 

5. Maintain and Update: 

o Regularly update your contact list to ensure accuracy. 

o Remove contacts that are no longer relevant. 

o Add new contacts as needed. 

 

 

Setting Up an Online Presence and Social Media 

Networking for Business: 

1. Blogs: 

o Purpose: Share valuable content, establish thought leadership, drive 

traffic to your website. 

o Platforms: WordPress, Medium, Blogger. 

o Content: Create informative and engaging blog posts related to your 

industry or business. 

o Promotion: Share your blog posts on social media and other 

platforms. 



2. Wikis: 

o Purpose: Create a collaborative knowledge base, share internal 

information, build a community. 

o Platforms: MediaWiki, Confluence, Notion. 

o Content: Develop a wiki with information about your company, 

products, or services. 

o Collaboration: Encourage employees or customers to contribute to 

the wiki. 

3. Podcasts: 

o Purpose: Share audio content, build brand awareness, connect with 

your audience. 

o Platforms: Spotify, Apple Podcasts, Google Podcasts. 

o Content: Create audio episodes related to your industry or business. 

o Promotion: Promote your podcast on social media and other 

platforms. 

 

Social Media Networking: 

1. Choose the Right Platforms: 

o Select social media platforms that are relevant to your target audience. 

o Examples: LinkedIn (professional networking), Facebook (general 

audience), Twitter (news and updates), Instagram (visual content). 

2. Create a Professional Profile: 

o Use a professional profile picture and cover photo. 

o Write a compelling bio that highlights your business and expertise. 

3. Share Valuable Content: 

o Post relevant articles, blog posts, and industry news. 

o Engage with your audience by responding to comments and 

messages. 

4. Network and Build Relationships: 

o Connect with other professionals in your industry. 



o Join relevant groups and participate in discussions. 

5. Use Social Media for Customer Service: 

o Respond to customer inquiries and complaints promptly. 

o Use social media to provide customer support. 

6. Track Your Results: 

o Monitor your social media analytics to see what's working and what's 

not. 

o Adjust your strategy as needed. 

 

 

Cloud Computing : 

Imagine you have a big, powerful computer somewhere else, not in your own home 

or office. You can access and use this computer over the internet. That's essentially 

cloud computing. 

Instead of storing files and running programs on your own computer, you're using 

resources that are located "in the cloud" (which just means on remote servers). 

Characteristics of Cloud Computing: 

1. On-Demand Self-Service:  

o You can access and use cloud resources whenever you need them, 

without needing to ask anyone for permission. 

o It's like renting a car – you get it when you want it. 

2. Broad Network Access:  

o Cloud services are accessible from anywhere with an internet 

connection, using various devices (computers, smartphones, tablets). 

o It's like having a library that's open 24/7, wherever you are. 

3. Resource Pooling:  

o The cloud provider shares its computing resources among many users. 



o It's like sharing a large apartment building – everyone gets their own 

space, but they share the building's infrastructure. 

4. Rapid Elasticity:  

o You can easily scale up or down your cloud resources as needed. 

o If you need more storage or computing power, you can get it quickly. If 

you need less, you can reduce it. 

o It's like having a flexible workspace – you can add or remove desks as 

your team grows or shrinks. 

5. Measured Service:  

o You pay only for the cloud resources you use. 

o It's like paying for electricity – you pay for how much you consume. 

 

 

How Data is Stored, Managed, and Shared on the Cloud : 

1. Storing Data:  

o Imagine a giant digital filing cabinet in a secure building. That's where 

your data is stored in the cloud. 

o Instead of saving files on your computer's hard drive, you're saving 

them on these remote servers. 

o The cloud provider makes sure the data is backed up and protected. 

2. Managing Data:  

o The cloud provider takes care of the technical stuff, like keeping the 

servers running, updating software, and ensuring security. 

o They use special software to organize and manage the data in the 

digital filing cabinet. 

o They also provide tools that allow you to manage your own data, like 

creating folders and setting permissions. 

3. Sharing Data:  



o You can share files and folders with others by giving them access to 

the digital filing cabinet. 

o You can set permissions to control who can view, edit, or download 

your files. 

o Cloud services often provide features for collaborating on documents in 

real-time. 

o It's like having a shared document that multiple people can work on at 

the same time. 

4. Accessing Data:  

o To get your data you simply log into your cloud account from any 

device with an internet connection. 

o You can then download, edit, or upload files as needed. 

o It's like accessing your files from any computer in the world. 

 

 

Advantages of Cloud Computing: 

• Cost Savings:  

o Reduces the need for expensive hardware and software. 

o Pay-as-you-go model eliminates upfront costs. 

o Lower maintenance and IT support expenses. 

• Scalability and Flexibility:  

o Easily scale resources up or down based on demand. 

o Quickly adapt to changing business needs. 

o Access to a wide range of services and applications. 

• Accessibility:  

o Access data and applications from anywhere with an internet 

connection. 

o Enables remote work and collaboration. 



o Consistent experience across multiple devices. 

• Increased Collaboration:  

o Facilitates real-time collaboration on documents and projects. 

o Easy sharing of files and information. 

• Automatic Updates:  

o Cloud providers handle software updates and maintenance. 

o Ensures access to the latest features and security patches. 

• Disaster Recovery:  

o Data backups and recovery are handled by the cloud provider. 

o Minimizes downtime and data loss in case of disasters. 

 

 

Disadvantages of Cloud Computing: 

• Internet Dependency:  

o Requires a stable internet connection for access. 

o Downtime can occur if the internet connection is unreliable. 

• Security and Privacy Concerns:  

o Data is stored on third-party servers, raising security concerns. 

o Risk of data breaches and unauthorized access. 

o Concerns about data privacy and compliance. 

• Vendor Lock-in:  

o Switching cloud providers can be complex and costly. 

o Dependence on a single vendor can limit flexibility. 

• Limited Control:  

o Less control over hardware and software infrastructure. 

o Dependence on the cloud provider's policies and procedures. 



• Performance Issues:  

o Performance can be affected by internet latency and network 

congestion. 

o Potential for downtime or service disruptions. 

• Compliance:  

o Depending on the industry, there can be very strict compliance rules 

about where data is stored. 

 

Cloud Service Providers and Their Products for Business: 

1. Amazon Web Services (AWS): 

o Products:  

▪ EC2 (Elastic Compute Cloud): Virtual servers for running 

applications. 

▪ S3 (Simple Storage Service): Object storage for data and files. 

▪ RDS (Relational Database Service): Managed database 

services. 

▪ Lambda: Serverless computing platform. 

▪ Many other services for networking, analytics, and AI. 

o AWS is very popular for its large selection of services. 

2. Microsoft Azure: 

o Products:  

▪ Virtual Machines: Infrastructure as a Service(IaaS) virtual 

servers. 

▪ Azure Storage: Storage solutions for various data types. 

▪ Azure SQL Database: Managed SQL database service. 

▪ Azure Active Directory: Identity and access management. 

▪ Microsoft 365 integration. 

o Azure is very popular with businesses that already use Microsoft 

products. 

3. Google Cloud Platform (GCP): 



o Products:  

▪ Compute Engine: Virtual machines. 

▪ Cloud Storage: Object storage. 

▪ Cloud SQL: Managed relational databases. 

▪ Kubernetes Engine: Container orchestration. 

▪ BigQuery: Data warehousing and analytics. 

o GCP is very popular with companies that require heavy data analysis. 

4. Salesforce: 

o Products:  

▪ Sales Cloud: CRM for sales management. 

▪ Service Cloud: Customer service and support. 

▪ Marketing Cloud: Marketing automation and analytics. 

▪ Platform Cloud: Platform for building custom applications. 

o Salesforce is very popular with companies that need CRM solutions. 

5. Oracle Cloud Infrastructure (OCI): 

o Products:  

▪ Compute, storage, networking, and database services. 

▪ Oracle database cloud services. 

▪ Applications like ERP, HCM, and CRM. 

o Oracle cloud is popular with companies that use oracle databases. 

 

 
  



Virtual Business Tools (Zoom, Microsoft Teams): 

These tools are crucial for modern business communication and collaboration, 

especially in remote work environments. 

• Zoom:  

o Purpose: Primarily known for video conferencing, but also offers chat, 

screen sharing, and webinar capabilities. 

o Key Features:  

▪ High-quality video and audio. 

▪ Screen sharing and annotation. 

▪ Virtual backgrounds. 

▪ Breakout rooms for smaller group discussions. 

▪ Recording capabilities. 

o Use Cases:  

▪ Virtual meetings and conferences. 

▪ Webinars and online presentations. 

▪ Online training and education. 

• Microsoft Teams:  

o Purpose: A comprehensive collaboration platform that integrates chat, 

video conferencing, file sharing, and application integration. 

o Key Features:  

▪ Team chat and channels. 

▪ Video and audio conferencing. 

▪ File sharing and co-authoring. 

▪ Integration with Microsoft 365 apps. 

▪ Task management. 

o Use Cases:  

▪ Team collaboration and communication. 



▪ Project management. 

▪ Internal communication and information sharing. 

▪ Virtual meetings and conferences. 

 

 

Telecommuting: 

Telecommuting is the practice of working from a location outside of a traditional 

office environment, typically from home, using technology to communicate and 

collaborate with colleagues. 

 

Advantages of Telecommuting: 

• Increased Flexibility:  

o Employees can work flexible hours and manage their own schedules. 

o Improved work-life balance. 

• Reduced Commuting Time and Costs:  

o Saves time and money on commuting. 

o Reduces stress associated with commuting. 

• Increased Productivity:  

o Fewer distractions and interruptions. 

o Improved focus and concentration. 

• Expanded Talent Pool:  

o Companies can hire employees from anywhere in the world. 

o Access to a wider range of skills and experience. 

• Reduced Overhead Costs:  

o Companies can save on office space, utilities, and other overhead 

expenses. 

• Environmental Benefits:  



o Reduced traffic congestion and carbon emissions. 

• Improved Employee Morale:  

o Increased job satisfaction. 

 

Disadvantages of Telecommuting: 

• Communication Challenges:  

o Difficulty in maintaining effective communication and collaboration. 

o Potential for miscommunication and misunderstandings. 

• Isolation and Loneliness:  

o Employees may feel isolated and disconnected from their colleagues. 

o Lack of social interaction. 

• Distractions at Home:  

o Potential for distractions from family, pets, or household chores. 

o Difficulty in separating work and personal life. 

• Difficulty in Monitoring Productivity:  

o Challenges in monitoring employee productivity and performance. 

o Requires trust and accountability. 

• Technical Issues:  

o Potential for technical problems with internet access, hardware, or 

software. 

o Requires reliable technology and support. 

• Security Risks:  

o Increased risk of data breaches. 

o Security protocols must be in place. 

• Work-Life Imbalance:  

o Some people have a hard time separating work from home life. 

  



 

Switching On a Computer: 

 

• Cold Boot:  

o This is when your computer is completely turned off. 

o How to do it:  

▪ Find the power button on your computer (usually a button with a 

power symbol). 

▪ Press the power button. 

▪ Wait for your computer to start up. This might take a little while. 

o Think of it like starting a car that's been parked for a long time. 

 

• Warm Boot (Restart):  

o This is when your computer is already on, but you want to restart it. 

o How to do it:  

▪ Most operating systems allow you to restart from the start menu, 

or by pressing a combination of keys (like Ctrl + Alt + Delete on 

some Windows systems). 

▪ Choose the "Restart" option. 

▪ Your computer will turn off and then turn back on automatically. 

o Think of it like restarting a car that's already running. 
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Putting a Computer on Sleep Mode: 

• Sleep mode is like putting your computer into a very low-power state. 

• It keeps your open programs and files in memory, so you can quickly resume 

where you left off. 

• How to do it:  

o On most computers:  

▪ Go to the start menu (or the Apple menu on a Mac). 

▪ Look for a "Sleep" or "Suspend" option. 

▪ Select it. 

o On many laptops, closing the lid will automatically put the computer 

into sleep mode. 

• What happens:  

o Your computer's screen will turn off. 

o The hard drive and other components will slow down or turn off. 

o Your computer will use very little power. 

• Waking up:  

o To wake your computer up, simply press a key on the keyboard, move 

the mouse, or press the power button. 

o Your computer will quickly return to where you left off. 

o Think of it like pausing a movie. 

 

 

 

 

 

 



Changing Your Desktop Background (Wallpaper): 

• Windows:  

o Right-click on an empty area of your desktop. 

o Select "Personalize." 

o In the "Background" section, you can choose:  

▪ "Picture" to select a single image. 

▪ "Solid colour" to use a plain colour. 

▪ "Slideshow" to have a rotating selection of images. 

o Browse to the image you want to use and select it. 

• macOS:  

o Click the Apple menu in the top-left corner and select "System 

Settings" (or "System Preferences" in older versions). 

o Click "Wallpaper." 

o Choose a wallpaper from the provided options or click the "+" button to 

add your own image. 

 

Correcting Date and Time: 

• Windows:  

o Right-click on the date and time display in the bottom-right corner of 

your taskbar. 

o Select "Adjust date/time." 

o You can:  

▪ Toggle "Set time automatically" on or off. 

▪ Manually set the date and time. 

▪ Change the time zone. 

• macOS:  



o Click the Apple menu and select "System Settings" (or "System 

Preferences"). 

o Click "Date & Time." 

o You can:  

▪ Toggle "Set time and date automatically" on or off. 

▪ Manually set the date and time. 

▪ Change the time zone. 

 

 

 Pinning Programs to the Taskbar: 

• Windows:  

o Find the program you want to pin (either in the Start menu or by 

searching). 

o Right-click on the program. 

o Select "Pin to taskbar." 

o To unpin a program, right-click on its icon on the taskbar and select 

"Unpin from taskbar." 

• macOS:  

o When a program is running, its icon appears in the Dock (which is 

similar to the taskbar). 

o Right-click (or Control-click) on the program's icon in the Dock. 

o Select "Options" and then "Keep in Dock." 

o To remove an icon, drag it off the dock. 

 

 

 

 

 



Sorting Desktop Icons: 

• Windows:  

o Right-click on an empty area of your desktop. 

o Select "Sort by." 

o Choose how you want to sort the icons (e.g., by name, size, item type, 

date modified). 

o You can also click view, and choose to allign icons to a grid. 

• macOS:  

o Right-click (or Control-click) on an empty area of your desktop. 

o Select "Sort By." 

o Choose how you want to sort the icons (e.g., by name, kind, date 

modified, size). 

o You can also click "Clean up by" to have the icons allign to a grid. 

 

 

Creating and Renaming a Folder: 

• Create a Folder:  

o Windows:  

▪ Right-click in the location where you want to create the folder 

(e.g., on the desktop, in a file explorer window). 

▪ Select "New" and then "Folder." 

▪ Type a name for the folder and press Enter. 

o macOS:  

▪ Right-click (or Control-click) in the desired location. 

▪ Select "New Folder." 

▪ Type a name and press Return. 

• Rename a Folder:  

o Windows:  



▪ Right-click on the folder. 

▪ Select "Rename." 

▪ Type the new name and press Enter. 

o macOS:  

▪ Click on the folder's name, or right click and select "Rename". 

▪ Type the new name and press Return. 

 

Copy a File into a Folder: 

• Right-click on the file you want to copy. 

• Select "Copy." 

• Navigate to the folder where you want to place the copy. 

• Right-click inside the folder and select "Paste." 

 

Duplicate Folders: 

• Right-click on the folder. 

• Select "Copy." 

• Right-click in the location where you want the duplicate. 

• Select "Paste." 

 

Transfer Files from Removable Storage to Computer and Back: 

• From Removable Storage to Computer:  

o Connect the removable storage device (e.g., USB drive) to your 

computer. 

o Open File Explorer (Windows) or Finder (macOS) and locate the 

removable drive. 

o Navigate to the files you want to transfer. 



o Copy or drag and drop the files to the desired location on your 

computer. 

• From Computer to Removable Storage:  

o Connect the removable storage device to your computer. 

o Open File Explorer (Windows) or Finder (macOS) and locate the files 

you want to transfer. 

o Copy or drag and drop the files to the removable drive. 

 

 Delete Files and Folders: 

• Right-click on the file or folder. 

• Select "Delete." 

• Confirm the deletion if prompted. 

 

 

Recover Files from Recycle Bin: 

• Windows:  

o Open the "Recycle Bin" on your desktop. 

o Right-click on the file you want to recover. 

o Select "Restore." 

• macOS:  

o Open the "Trash" icon in the Dock. 

o Right-click (or Control-click) on the file. 

o Select "Put Back." 

 

Open and Import Files of Different Types: 

• Double-click on the file. 

• If the file type is recognized, it will open in the associated application. 



• Some applications have import features that allow you to open files of 

different formats (e.g., importing a .csv file into Excel). 

 

Save Files Using Appropriate Filenames: 

• When saving a file, use a filename that is:  

o Descriptive: Clearly indicates the file's content. 

o Concise: Avoid overly long filenames. 

o Consistent: Follow a naming convention. 

o Avoid special characters: Stick to letters, numbers, underscores, and 

hyphens. 

 

Save and Export in the File Format of an Application Package: 

• Saving:  

o In the application (e.g., Word, Excel, PowerPoint, Access), go to "File" 

and select "Save" or "Save As." 

o Choose the desired file format from the "Save as type" (Windows) or 

"File Format" (macOS) dropdown menu. 

o Examples:  

▪ .docx (Microsoft Word document) 

▪ .doc (Older Microsoft Word document) 

▪ .xls or .xlsx (Microsoft Excel spreadsheet) 

▪ .accdb (Microsoft Access database) 

▪ .pptx (Microsoft PowerPoint presentation) 

• Exporting:  

o Some applications have an "Export" option in the "File" menu. 

o Exporting is used when you need to save a file in a different format that 

is not the programs native file type. 



o This is often used to create PDF files, or other file types. 

 

 

Setting a Default Printer : 

Setting a default printer ensures that whenever you print from an application, the 

document automatically goes to that printer unless you specify otherwise. Here is 

how to do it in Windows and macOS: 

Windows: 

1. Open Settings: 

o Click the Start button (Windows logo) in the bottom-left corner of your 

screen. 

o Click the gear icon (Settings). 

2. Go to Devices: 

o In the Settings window, click "Devices." 

3. Select Printers & Scanners: 

o In the left-hand menu, click "Printers & scanners." 

4. Choose Your Printer: 

o You'll see a list of installed printers. Click on the printer you want to set 

as the default. 

5. Manage the Printer: 

o Click the "Manage" button. 

6. Set as Default: 

o Click the "Set as default" button. 

7. Let Windows Manage my Default Printer: 



o Windows has a setting that allows windows to manage your default 

printer. If you want to manage it yourself, make sure that the option that 

says "Let Windows manage my default printer" is unchecked. 

macOS: 

1. Open System Settings (or System Preferences): 

o Click the Apple menu in the top-left corner of your screen. 

o Select "System Settings" (or "System Preferences" in older macOS 

versions). 

2. Go to Printers & Scanners: 

o In System Settings, click "Printers & Scanners" in the sidebar. 

3. Select Default Printer: 

o At the bottom of the "Printers & Scanners" window, you'll see a 

dropdown menu labeled "Default printer." 

o Click the dropdown menu and select the printer you want to use as the 

default. 

 
  



 

Word Processor. 

1. Loading a Word Processor: 

• Action:  

o Find the icon for your chosen word processor (e.g., Microsoft Word, 

Google Docs, LibreOffice Writer). 

o Double-click the icon to open the program. 

• Result:  

o The word processor application window will appear on your screen. 

 

2. Creating a New Document, Formatting Text and Paragraphs: 

• Creating a New Document:  

o Action:  

▪ In the word processor, click "File" in the top menu. 

▪ Select "New" or "New Document." 

▪ Choose "Blank Document" (or a similar option). 
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o Result:  

▪ A new, empty document will open. 

 

• Formatting Text and Paragraphs:  

o Action:  

▪ Type some text into the document. 

▪ Select the text you want to format (click and drag). 

▪ Font: Use the font dropdown menu to change the font type 

(e.g., Arial, Times New Roman). Use the number box next to it 

to change the font size. Use the colour selector to change the 

font colour. 

 

▪ Text Alignment: Click the alignment buttons (left, canter, right, 

justify) in the toolbar. 



 

▪ Text Enhancement: Click the bold (B), italic (I), and underline 

(U) buttons. 

 

▪ Paragraph Formatting:  

▪ Select the paragraph(s) you want to format. 

▪ Use the line spacing button to adjust the spacing between 

lines. 

 

 

v 

▪ Use the indent buttons to increase or decrease paragraph 

indents. 

 

 

 

▪ Use the paragraph settings menu to change the spacing 

before or after the paragraph. 

o Result:  

▪ The selected text and paragraphs will be formatted according to 

your chosen options. 

 



3. Working with Text and Pictures: 

• Inserting Pictures:  

o Action:  

▪ Click "Insert" in the top menu. 

 

▪ Select "Picture" or "Image." 

 

▪ Browse to the image file on your computer and click "Insert." 

 

 

 

 

 

 

 

 

o Result:  

▪ The image will appear in your document. 



 

 

 

 

 

 

 

• Text Wrapping:  

o Action:  

▪ Click on the inserted image. 

▪ Look for the text wrapping options (usually an icon or a menu 

option). 

▪ Choose a wrapping style (e.g., "Square," "Tight," "Through"). 

 

o  



 

o Result:  

▪ The text will flow around the image according to the selected 

wrapping style. 

▪ Example Infront of text 

 

• Bullets and Numbering:  



o Action:  

▪ Type a list of items. 

▪ Select the list. 

▪ Click the bullet or numbering button in the toolbar. 

 

o Result:  

▪ The list will be formatted with bullets or numbers. 

4. Creating and Formatting SmartArt: 

• Inserting SmartArt:  

o Action:  

▪ Click "Insert" in the top menu. 

▪ Select "SmartArt." 

 

▪ Choose a SmartArt graphic from the gallery. 

▪ Click "OK." 

 

 

 

 

 



o Result:  

▪ The SmartArt graphic will appear in your document. 

 

• Formatting SmartArt:  

o Action:  

▪ Click on the SmartArt graphic. 

▪ Use the SmartArt design and format tabs to change colours, 

styles, and layouts. 

o Result:  

▪ The SmartArt graphic will be customized according to your 

changes. 

5. Using and Editing Templates: 

• Using Templates:  

o Action:  

▪ Click "File" > "New." 

▪ Search for or browse available templates. 

▪ Select a template and click "Create." 

 

 

 

 



o  

o Result:  

▪ A new document will open, based on the selected template. 

 

 

 

 

 

 

 

 

 

 

• Editing Templates:  

o Action:  

▪ Click on the template's placeholders and replace them with your 

own content. 

▪ Change colors, fonts, and layouts as needed. 



o Result:  

▪ The template will be customized with your own information. 

 

 

6. Creating or Editing Headers and Footers: 

• Inserting Headers and Footers:  

o Action:  

▪ Click "Insert" in the top menu. 

▪ Select "Header" or "Footer." 

▪ Choose a header or footer style. 

 

 

 

 

 

o Result:  

▪ The header or footer area will become active. 

• Adding Information:  

o Action:  

▪ Type text, insert page numbers, or add other information into the 

header or footer area. 

o Result:  

▪ The information will appear in the header or footer on each 

page. 

• Customization:  

o Action:  



▪ Use the header and footer design tools to change fonts, styles, 

and alignment. 

o Result:  

▪ The header or footer will be customized according to your 

changes. 

 

 

 

 

 

Highlighting (Selecting): 

• Purpose: To choose a section of text or numbers for further actions. 

• How:  

o Mouse: Click and drag your mouse cursor over the desired text. 

o Keyboard:  

▪ Hold Shift and use the arrow keys to select text. 

▪ Ctrl + A (Windows) or Cmd + A (macOS) selects all text. 

• Result: The selected text will be highlighted, usually with a different 

background colour. 

 

2. Deleting: 

• Purpose: To remove text or numbers. 

• How:  

o Select the text you want to delete. 

o Press the Delete or Backspace key. 

• Result: The selected text will be removed. 

 

3. Moving (Cut and Paste): 

• Purpose: To relocate text or numbers to a different location. 

• How:  



o Select the text you want to move. 

o Cut:  

▪ Right-click and select "Cut," or 

▪ Use Ctrl + X (Windows) or Cmd + X (macOS). 

o Position the cursor where you want to move the text. 

o Paste:  

▪ Right-click and select "Paste," or 

▪ Use Ctrl + V (Windows) or Cmd + V (macOS). 

• Result: The text will be removed from its original location and placed in the 

new location. 

 

4. Copying (Copy and Paste): 

• Purpose: To create a duplicate of text or numbers in a different location. 

• How:  

o Select the text you want to copy. 

o Copy:  

▪ Right-click and select "Copy," or 

▪ Use Ctrl + C (Windows) or Cmd + C (macOS). 

o Position the cursor where you want to place the copy. 

o Paste:  

▪ Right-click and select "Paste," or 

▪ Use Ctrl + V (Windows) or Cmd + V (macOS). 

• Result: A copy of the text will be placed in the new location, while the original 

text remains unchanged. 

 

5. Drag and Drop: 

• Purpose: To move text or numbers to a different location using the mouse. 

• How:  



o Select the text you want to move. 

o Click and hold the selected text. 

o Drag the text to the desired location. 

o Release the mouse button. 

• Result: The text will be moved to the new location. 

• Copy Drag and Drop:  

o To copy instead of move, hold the CTRL key (Windows) or the Option 

Key (MacOs) while dragging and dropping. 

 

 

Mail merge 

Scenario: You're organizing a company holiday party and want to send personalized 

invitations to your employees. 

 

1. Creating the Main Document (Invitation Template): 

• Open Word Processor: Launch Microsoft Word (or your preferred word 

processor). 

• Create Invitation:  

o Type the body of your invitation, leaving placeholders for personal 

details. 

o Example:  

o Dear <<FirstName>> <<LastName>>, 

o  

o You're invited to our annual company holiday party! 

o  

o Date: December 20th 

o Time: 7:00 PM 

o Location: The Grand Ballroom 

o  

o We look forward to celebrating with you! 

o  



o Sincerely, 

o [Your Name/Company Name] 

o Note: The <<FirstName>> and <<LastName>> are our merge field 

placeholders 

 

 

 

 

2. Creating the Data Source (Recipient List): 

• Open Spreadsheet: Open Microsoft Excel (or Google Sheets, etc.). 

 

 

 

 

 

 

 

 

 

• Create Columns:  

o Create columns with headers that match your merge field placeholders: 

FirstName, LastName, Department, Email. 

 

• Enter Data:  

o Fill in the rows with employee information. 

• Save Data Source: Save the spreadsheet as an Excel workbook (.xlsx). 

 

 

 

 

 

 

 



3. Starting the Mail Merge: 

• In Word:  

o Go to the "Mailings" tab. 

o Click "Start Mail Merge" -> "Letters." 

4. Selecting Recipients: 

• Click "Select Recipients" -> "Use an Existing List." 

• Browse: Navigate to and select your Excel workbook. 

• Select Sheet: Choose the correct sheet that contains your data. 

• Click "OK." 

5. Inserting Merge Fields: 

• Place Cursor: In your invitation template, place the cursor where you want to 

insert the FirstName merge field. 

• Click "Insert Merge Field" -> "FirstName." 

• Repeat: Do the same for LastName. 

6. Previewing Results: 

• Click "Preview Results." 

• Navigate: Use the arrow buttons to cycle through the personalized invitations. 

• Check: Verify that the data is correctly inserted. 

7. Finishing and Merging: 

• Click "Finish & Merge" -> "Edit Individual Documents" -> "All." 

• New Document: A new Word document will be created, containing 

personalized invitations for each recipient. 

• Print/Email: You can now print or email these invitations. 

 

Selecting Mail Merge Recipients and Troubleshooting Errors: 

• Selecting Recipients:  

o Filtering:  

▪ In the "Select Recipients" dialog, you can click "Edit Recipient 

List." 



▪ Here, you can check/uncheck recipients, sort, or use "Filter" to 

select recipients based on criteria (e.g., only those in the "Sales" 

department). 

o Data Validation:  

▪ Before starting the mail merge, always double-check your data 

source for accuracy. 

▪ Ensure that email addresses are correct if you plan to send 

invitations via email. 

• Troubleshooting Errors:  

o Missing Data:  

▪ If a recipient's name is missing, check your data source for blank 

cells. 

o Incorrect Data:  

▪ If data is incorrect, edit your data source and restart the mail 

merge. 

o Formatting Issues:  

▪ If names or other data appear in the wrong font or size, adjust 

the formatting in your invitation template. 

o Merge Field Errors:  

▪ If merge fields don't appear, ensure that:  

▪ The field names in your data source match the names 

used in "Insert Merge Field." 

▪ You've selected the correct data source. 

o Blank Pages:  

▪ If you get extra blank pages, make sure there are no extra 

paragraph marks at the end of your main document. 

o Email Issues:  

▪ If sending emails, verify your email settings in Word. 



▪ Test with a small group before sending to everyone. 

▪ If data from the excel sheet is not displaying correctly, 

sometimes saving the excel sheet as a .csv file, and then 

importing that file will solve the issue. 

 

1. Creating Tables and Columns: 

• In Microsoft Word (or similar word processors):  

o Go to the "Insert" tab. 

o Click "Table." 

o You can:  

▪ Drag your mouse over the grid to select the desired number of 

rows and columns. 

▪ Click "Insert Table" to enter the number of rows and columns 

manually. 

▪ Draw a table. 

• Result: A table with the specified dimensions will be inserted into your 

document. 

 

2. Creating and Editing a Table with a Specified Number of Rows and 

Columns: 

• Creating:  

o Follow the steps above to create a table with the exact number of rows 

and columns you need. 

• Editing:  

o Adding/Deleting Rows and Columns:  

▪ Right-click inside the table. 

▪ Select "Insert" or "Delete." 

▪ Choose to insert or delete rows or columns. 



o Resizing Rows and Columns:  

▪ Hover your mouse over the table's border until the cursor 

changes to a double-sided arrow. 

▪ Click and drag to resize the row or column. 

o Merging Cells:  

▪ Select the cells you want to merge. 

▪ Right-click and select "Merge Cells." 

o Splitting Cells:  

▪ Right click the cell you want to split. 

▪ Select "Split cells". 

▪ Enter the number of rows and columns you want to split the cell 

into. 

 

3. Placing Text or Objects in a Table: 

• Text:  

o Click inside a cell. 

o Type your text. 

o You can format the text as you would in any other part of the 

document. 

• Objects (Pictures, Shapes, etc.):  

o Click inside the cell where you want to place the object. 

o Go to the "Insert" tab. 

o Select the object you want to insert (e.g., "Picture," "Shapes"). 

o Browse to the file or select the shape and insert it. 

o You may need to resize the object to fit the cell. 

4. Placing Texts or Objects into Columns: 

• Within a Table:  



o Tables inherently organize content into columns. 

o Simply click inside the desired cell within a column and add your text or 

object. 

 

• Without a Table (Using Tabs or Columns):  

o Tabs:  

▪ Type your content, and press the tab key to move to the next 

column. 

▪ This method is not very precise. 

o Columns (in Word Processors):  

▪ Select the text you want to divide into columns. 

▪ Go to the "Layout" tab (or "Page Layout" in older versions). 

▪ Click "Columns" and choose the number of columns. 

▪ This creates text columns that flow from one to the next. 

 

5. Inserting Borders: 

• For the Entire Table:  

o Click inside the table. 

o Go to the "Table Design" tab (or "Table Tools Design" in older 

versions). 

o Click the "Borders" dropdown menu. 

o Choose the border style you want (e.g., "All Borders," "Outside 

Borders"). 

• For Specific Cells or Borders:  

o Select the cells or borders you want to modify. 

o Use the "Borders" dropdown menu to apply the desired border style. 



o You can also select "Borders and Shading" from the dropdown to 

access more advanced border customization options. 

• Line Style and Colour:  

o In the "Table Design" tab, you can also change the line style (e.g., 

solid, dashed) and colour of the borders. 

 

 

 

Creating business Documents 

1. Business Plan: 

• Step 1: Start a New Document:  

o Open Microsoft Word. 

o Click "File" > "New" > "Blank document." 

 

• Step 2: Structure Your Plan:  

o Create headings for each section:  

▪ Executive Summary 

▪ Company Description 

▪ Market Analysis 

▪ Organization and Management 

▪ Service or Product Line 

▪ Marketing and1 Sales Strategy 

▪ Financial Projections 

▪ Funding Request (if applicable) 

o Use Heading 1 for main sections, Heading 2 for subsections, etc. 

 



• Step 3: Fill in the Content:  

o Write the content for each section, providing clear and concise 

information. 

o Use tables, charts, and graphs to present data visually. 

 

• Step 4: Format:  

o Use styles for consistent formatting (see "Styles" section below). 

o Add a title page with company name, plan title, and date. 

o Insert a table of contents (References > Table of Contents). 

 

 

2. Memorandum (Memo): 

• Step 1: Start a New Document:  

o Open Microsoft Word. 

o Click "File" > "New" > "Blank document." 

 

• Step 2: Create the Header:  

o Type the following at the top of the document:  

▪ MEMORANDUM 

▪ TO: [Recipient's Name/Department] 

▪ FROM: [Your Name] 

▪ DATE: [Date] 

▪ SUBJECT: [Brief Subject Line] 

o Use a clear, professional font. 

 

 



• Step 3: Write the Body:  

o Write the memo's content in a clear, concise, and direct manner. 

o Use paragraphs to separate ideas. 

o Use bullet points or numbered lists for clarity when needed. 

 

• Step 4: Format:  

o Use styles for consistency. 

o Keep the memo to one or two pages. 

 

 

3. Different Types of Letters (Business Letters): 

• Step 1: Start a New Document:  

o Open Microsoft Word. 

o Click "File" > "New" > "Blank document." 

 

• Step 2: Use a Letter Template (Optional):  

o Word provides letter templates (File > New, search for "letter"). 

o Customize the template with your information. 

 

• Step 3: Create the Letterhead:  

o Include your company's name, address, phone number, and email. 

 

• Step 4: Add the Date and Recipient Information:  

o Type the date. 

o Type the recipient's name, title, and address. 

 



• Step 5: Write the Body:  

o Use a professional tone. 

o Clearly state the purpose of the letter. 

o Use paragraphs to organize your thoughts. 

 

• Step 6: Add a Closing and Signature:  

o Use a professional closing (e.g., "Sincerely," "Best regards"). 

o Leave space for your signature. 

o Type your name and title. 

 

• Step 7: Format:  

o Use styles for consistency. 

 

4. Reports: 

• Step 1: Start a New Document:  

o Open Microsoft Word. 

o Click "File" > "New" > "Blank document." 

 

• Step 2: Structure the Report:  

o Create headings for each section:  

▪ Title Page 

▪ Executive Summary 

▪ Introduction 

▪ Methodology 

▪ Findings 

▪ Conclusions 



▪ Recommendations 

▪ Appendices (if applicable) 

o Use Heading styles for consistency. 

 

• Step 3: Fill in the Content:  

o Write the content for each section, using clear and concise language. 

o Use tables, charts, and graphs to present data. 

 

• Step 4: Format:  

o Use styles for consistency. 

o Add page numbers, headers, and footers. 

o Insert a table of contents (References > Table of Contents). 

 

 

5. Create, Modify, Update, and Apply Styles: 

• Creating Styles:  

o Select the text you want to format. 

o Format the text (font, size, color, etc.). 

o In the "Styles" group on the "Home" tab, click the "More" arrow. 

o Click "Create a Style." 

o Give the style a name and click "OK." 

 

• Modifying Styles:  

o Right-click on a style in the "Styles" gallery. 

o Select "Modify." 

o Make your changes and click "OK." 



• Updating Styles:  

o If you change the formatting of text that has a style applied to it, you 

can right click on the style in the style gallery, and select "Update [Style 

Name] to match selection." 

 

• Applying Styles:  

o Select the text you want to format. 

o Click on the desired style in the "Styles" gallery. 

 

 

6. Perform Spelling and Grammar Check: 

• How:  

o Go to the "Review" tab. 

o Click "Spelling & Grammar." 

o Word will highlight errors and provide suggestions. 

o Accept or ignore the suggestions. 

 

 

7. Print Out Finished Documents: 

• How:  

o Click "File" > "Print." 

o Select your printer. 

o Adjust print settings (number of copies, page range, etc.). 

o Click "Print." 

 

 



 

  



 

 

 

 

 

 

 

 

 

OPENING MICROSOFT EXCEL 
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MICROSOFT EXCEL 
 

Click Blank 



 

 

 

 

 

 

Here’s a simple Sheet Created. 

From here I will take your understanding of Excel Spreadsheets to the next level 

 

 

 

 

 

 

 

 

 

 

First we will need to Bold the headers 
Click exactly here once, this will highlight 

the headers. Hit Ctrl + B to bold the text.  

Here’s the result: 

As you can see the header name Price 

Per…Item is not clear 

We are now required to increase the 

length of the cell we want to be clear.  

Here’s how you can do it. 



 

  

 

 

 

  

 

 

 

 

 

Now for the basic calculations I have added the cell for finding the total of the quantity, 

price and total price 

 

To calculate the total Price of each item you have to do the basic math of multiplying the 

Price per item with the quantity so you will need to click the cell you want the total to be, 

then type = then click the cell with 34 (cell B2).   

 

Now continue to type in the total price cell D2- after =B2 type * then click the cell with a 12 

(Cell C2) then press enter on your keyboard. This will automatically Calculate the Total price 

of all the product items. 

 

 

 

Right at where this pointer 

is is where you should put 

your cursor. The cursor will 

change to a + sign sort of. 

Right at that point left click 

your mouse then move it to 

the right… see how its 

changing the cell width. 

Also do the same for other 

cells to create a better view 



 

Now to calculate everything else you don’t need to repeat the same steps no more. Heres 

What you have to do- Left-Click on that green dot pointed then move down until it 

highlights the “Barrow Total Price” (Cell D5). As you highlight it automatically 

calculates the total for the other product items. 

 

  

Now for the total of the Quantity 

Click Cell B6 then type “=SUM(B2:B5)” then hit enter. This Will calculate the total of all 

products. 

 

 

 

 

 

 

 

Heres some formulas you need to perform some 

Other calculations: 

Finding the average: 

=AVERAGE(B1, B2, B3) 

Counting the total number of cells in a range that contains a number. 

=COUNT(B1:B4) 

Finding the minimum. 

=MIN(B1:B4) 

Finding the maximum. 

=MAX(B1:B4) 

 

Now lets get ready to print the worksheet. Do don’t simply print the worksheet. You will 

need to first put some guide lines on the Table you created. 

And for the corresponding cells you 

will not again need to repeat the 

same process. You have to simply 

point to the bottom left corner of 

the cell B6 then drag it to cover 

those 2 cells to the right 



 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 Generating Appropriate Graphs from Given Data: 

• Select Data:  

Click here then drag up to the top 

left corner to highlight the whole 

table 

Click All bordersto finish the job! Press 

Control + P on your keyboard to see how 

structured it looks 



o Highlight the cells containing the data you want to graph, including any 

headers. 

o  

• Insert Chart:  

o Go to the "Insert" tab. 

o  

o In the "Charts" group, choose the type of chart you want (e.g., Column, 

Line, Pie). 

 

 

 



o Excel will create a default chart based on your selected data. 

 

• Customize Chart:  

o Chart Title: Click on the chart title to edit it. 

o Axis Titles: If needed, add axis titles by clicking the "+" button next to 

the chart and checking "Axis Titles." 

o Data Labels: Add data labels to display the values directly on the chart 

by clicking the "+" button next to the chart and checking "Data Labels." 

o Legend: Adjust the legend position or remove it by clicking the "+" 

button next to the chart and checking "Legend." 

o Chart Design: Use the "Chart Design" tab to change the chart style, 

colours, and layout. 

o Format Data Series: Right-click on a data series (e.g., a column in a 

column chart) and select "Format Data Series" to customize its 

appearance. 

 

 

Saving the Spreadsheet: 

• Save:  

o Click "File" > "Save" or "Save As." 

o Choose the location where you want to save the file. 

o Enter a filename. 

o Select the file type (.xlsx is the default). 

o Click "Save." 

 

Printing Spreadsheet or Specified Window: 

• Print Preview:  

o Go to "File" > "Print." 

o The print preview will show you how the spreadsheet will look when 

printed. 



• Print Settings:  

o Copies: Enter the number of copies. 

o Orientation: Choose portrait or landscape. Landscpae is better for 

longer tables kuti anyatsbobuda. 

o Print Active Sheets/Entire Workbook/Selection:  

▪ "Print Active Sheets": Prints only the currently selected sheet. 

▪ "Print Entire Workbook": Prints all sheets in the workbook. 

▪ "Print Selection": Prints only the selected cells or chart. 

• Print:  

o Click the "Print" button. 

 

 

 

Creating basic business documents. 

Invoices: 

1. Set Up the Invoice Template: 

o Company Information: In the top section, include your company's 

name, address, logo (Insert > Picture), and contact details. 

o Invoice Details: Add fields for:  

▪ Invoice Number 

▪ Invoice Date 

▪ Customer Name 

▪ Customer Address 

o Itemized List: Create a table with columns for:  

▪ Item Description 

▪ Quantity 



▪ Unit Price 

▪ Total (Quantity * Unit Price) 

o Totals: Include fields for:  

▪ Subtotal 

▪ Tax (if applicable) 

▪ Total Amount Due 

o Payment Terms: Add a section for payment terms and instructions. 

 

2. Enter Data: 

o Fill in the invoice details and itemized list for each customer. 

o Use formulas to calculate the "Total" for each item (e.g., =C2*D2). 

o Use the SUM function to calculate the "Subtotal" and "Total Amount 

Due." 

o Use a formula to calculate the tax, if applicable (e.g., 

=Subtotal*TaxRate). 

 

3. Format the Invoice: 

o Use borders, colors, and fonts to make the invoice look professional. 

o Adjust column widths and row heights as needed. 

o Format numbers as currency. 

4. Save and Print: 

o Save the invoice as an Excel file or PDF. 

o Print the invoice. 

 

 

 

 

 



Receipts: 

1. Set Up the Receipt Template: 

o Company Information: Include your company's name, address, and 

logo. 

o Receipt Details: Add fields for:  

▪ Receipt Number 

▪ Receipt Date 

▪ Customer Name 

▪ Payment Method 

o Itemized List: Create a table with columns for:  

▪ Item Description 

▪ Amount 

o Total: Include a field for the "Total Amount Received." 

o Thank You Message: Add a thank you message. 

 

2. Enter Data: 

o Fill in the receipt details and itemized list. 

o Use the SUM function to calculate the "Total Amount Received. 

 

3. Format the Receipt: 

o Use clear and concise formatting. 

o Format numbers as currency. 

 

4. Save and Print: 

o Save the receipt as an Excel file or PDF. 

o Print the receipt. 

 

 



Simple Financial Statements  

1. Set Up the Income Statement Template: 

o Company Name and Period: Include your company's name and the 

reporting period (e.g., "Income Statement for the Year Ended 

December 31, 2023"). 

o Revenue: Add fields for:  

▪ Sales Revenue 

▪ Other Revenue 

▪ Total Revenue 

o Cost of Goods Sold (COGS): Add a field for COGS. 

o Gross Profit: Calculate Gross Profit (Total Revenue - COGS). 

o Operating Expenses: Add fields for various operating expenses (e.g., 

salaries, rent, utilities). 

o Total Operating Expenses: Calculate Total Operating Expenses 

(SUM of all expenses). 

o Operating Income: Calculate Operating Income (Gross Profit - Total 

Operating Expenses). 

o Other Income/Expenses: Add fields for other income and expenses 

(e.g., interest income, interest expense). 

o Net Income: Calculate Net Income (Operating Income + Other Income 

- Other Expenses). 

 

2. Enter Data: 

o Fill in the revenue and expense data. 

o Use formulas to calculate the totals and subtotals. 

 

3. Format the Income Statement: 

o Use clear and consistent formatting. 

o Format numbers as currency. 

o Use borders and colors to highlight important sections. 



4. Save and Print: 

o Save the income statement as an Excel file or PDF. 

o Print the income statement. 

 
 

 

 

 

Creating a Database in Microsoft Access 

Here is a breakdown of how to create a database in Microsoft Access: 

 

1. Finding and Opening Access: 

• Click on the Start menu and search for "Microsoft Access." 

• Alternatively, if you have icons pinned to your taskbar, look for the Access 

icon (usually a blue square with an "A" in it). 

• Click on the icon to launch the application. 

 

 

 

 

 

 

 

 

2. Now Create a Blank Database: 

• Once Access opens, you'll see the welcome screen with various options. 

• In the "New" section, click on "Blank Database." 

 

 

 

Search Here 

Click to Open 



 

 

• A window will pop up prompting you to name your database. Choose a 

descriptive name that reflects the data you'll be storing (e.g., 

"CustomerContacts"). 

• You can also choose a location to save your database using the "Browse" 

button. By default, it will save in your Documents folder. 

• Click "Create" to create the new blank database. 

 

 

 

 

 

 

 

 

3. Building Your Table: 

• Access will open your new database and display a table named "Table1" 

• Click  Design view.. A small window will pop-up on the center. Change the 

“table1” to the name your question paper asks you to then click OK. 

 

 

 

 

 

 

 

• This is where you'll define your data structure. 

• Click in the "Click to Add" column header and select the data type for your first 

field. Common choices include:  

o Short Text: Names, email addresses (up to 255 characters) 

o Number: Numbers for calculations (e.g., phone numbers) 

o Date/Time: Dates and times 

Database Name 

Select your Folder and Save 

Click Create 

Click Once 

This will take you to the 

design view 



o Currency: Monetary values 

• Rename the column header by clicking on it and typing a descriptive name 

like "Name," "Surname," "Email," or "Phone." 

• Repeat this process for all the fields you want to store in your database. 

 

 

 

  

 

 

 

 

 

 

4. Adding Records: 

• Each row in the table represents a single record. 

• To add a new record, click on the blank row at the bottom of the table. 

• Enter the data for each field in the corresponding column. 

• Press Enter or Tab to move to the next field and continue entering data. 

 

 

 

 

 

 

Right Click the key  

Click on Primary Key 
To remove the 

primary key  

Click here to add headers like 

Name Surname Class Couse chii 

chii  

Click here to change the data type 

to match the question papers 

needs… sort of like Date/time, 

Number, Text chichiii  

Click here  to go back where you 

can now enter the people and 

stuff 



 

 

5. Deleting Records: 

• Select the entire row of the record you want to delete by clicking on the grey 

box to the left of the record. 

• Press the Delete key on your keyboard, or right-click on the selected row and 

choose "Delete Record." 

 

 

 

 

 

 

6. Editing Records: 

• Click on any cell within the record you want to edit. 

• Make your changes directly in the cell and press Enter to save the edits. 

7. Sorting Records: 

• Click on the header of the column you want to sort by. 

• A small arrow will appear next to the header. Click the arrow again to toggle 

between ascending (A to Z) and descending (Z to A) sorting. 

8. Printing Selected Fields: 

Here you enter all records you 

are assigned to enter 

Right Click exactly 

here 



• In Datasheet view, select the specific fields (columns) you want to print by 

holding Ctrl and clicking on the column headers. 

• Go to the File menu and choose "Print." 

• In the Print window, you can choose which fields to print (if you didn't select 

them earlier), adjust the layout, and preview the printout before sending it to 

your printer. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Best Practices: 

In your exam, when answering the database questions… You 

will need to make use of Microsoft word. For example if the 

question asks you to create a table and fill in with the 

information provided…  In the Questions whenever you see 

where they say “..and Print”  Open Word  then write  like 

this: 

 Question 1a) 

 

Question 1b) 

…So 

on and so forth 

 

 

Click windows and search Snipping tool. 

When ever you see where they say …and 

print. Open the snipping too then click on 

new. Your screen will dim then you will have 

to navigate your mouse cursor to the corner 

of the area you want to take a screenshot 

then left click mouse and drag to cover the 

whole area you want a shot on. 

 For example if the question asks you to 

create and fill a table then  print. You Click on 

New then at the top left corner of your table 

drag your mouse to the bottom richt corner 

to take a shot of the whole table then just 

release the click. 

Go to word where you wrote  

Question 1a) 

Then put your cursor right under the 

“Question 1”- make sure it’s a line blinking.  

Then right there on your keyboard click Ctrl + 

V to paste that screenshot you captured… Do 

the same for every question which asks you 

to print….. 



 

 

CREATING A QUERY 

1. Creating a Query: 

There are two main ways to create a query: 

• Query Wizard: This is a step-by-step approach that guides you through 

selecting tables, fields, and criteria. 

• Design View: This offers more flexibility for complex queries. 

 

Here, we'll use Design View for more control over the criteria. 

• Go to the "Create" tab on the Access ribbon. 

• In the "Queries" group, click on "Query Design." 

• A new window will open where you can add tables to your query. 

 

 

 

 

 

 

 

2. Adding Tables and Fields: 

• In the "Show Table" dialog box, select the table(s) containing the data you 

want to query. 

• Click "Add" to include them in the query window. 

• Double-click on the fields you want to display in the query results from each 

table. These fields will appear in the grid below. 

 

 

 

 

 

 Click Add then 

Close Double Click on each to 

add thenm to where we 

will put our conditions 

and criteria stuff 

Click Here 



 

 

3. Setting Criteria: 

Now comes the magic of filtering data! 

• In the "Criteria" row of the grid, you can specify conditions for each field. Here 

are some examples based on your requests: 

o Find names starting with "E": 

▪ In the "Criteria" row for the "Name" field, type Like "E*" (the 

asterisk acts as a wildcard for any characters following "T"). 

 

 

 

 

Here’s other Criteria that may happen to appear in your exam. It might not come as it 

is here, this is just an example by the keywords and format for criteria is just the 

same. Most of them are not common in exams but for learning purposes you might 

need to explore most of them. 

 

• Criteria for Including Records in Microsoft Access Queries 

• This table summarizes how to create queries in Microsoft Access to include 

records based on various criteria: 

Type here then Run 

Here the Query 



 

 

To include 

records that... 

Use this criterion Query Result Notes 

Exactly match a 

value 

"Blackgift" 

(replace "value" 

with the actual 

value) 

Returns records 

where the field is set 

to the exact value. 

Example: "Blackgift" returns 

records where the Name field is set 

to "China". 

Do not match a 

value 

Not "Mexico" Returns records 

where the field is set 

to a value other than 

the specified value. 

Example: Not "Mexico" returns 

records where the CountryRegion 

field is set to a country/region other 

than Mexico. 

Begin with a 

specified string 

Like "P*" Returns records for 

all fields that start 

with the Letter P 

The asterisk (*) is a wildcard that 

matches any number of characters 

following the "string". 

Do not begin 

with a specified 

string 

Not Like "P*" Returns records for 

all fields that do not 

start with P. 

 

Contain the 

specified string 

Like 

"*string*" 

Returns records for 

all fields that contain 

the specified string 

anywhere within the 

value. 

 

Do not contain 

the specified 

string 

Not Like 

"*string*" 

Returns records for 

all fields that do not 

contain the specified 

string. 

 

End with the 

specified string 

`Like "*string"`` Returns records for 

all fields that end with 

the specified string. 

 

Do not end with 

the specified 

string 

Not Like 

"*string" 

Returns records for 

all fields that do not 

end with the specified 

string. 

 

Contain null 

values 

Is Null Returns records 

where the field has 

no value (null). 

 

Do not contain 

null values 

Is Not Null Returns records 

where the field has a 

value (not null). 

 



Contain zero-

length strings 

(blank) 

"" (empty quotes) Returns records 

where the field is set 

to a blank value. 

 

Do not contain 

zero-length 

strings (not 

blank) 

Not "" Returns records 

where the field has a 

non-blank value. 

 

Contain null 

values or zero-

length strings 

"" Or Is Null Returns records 

where the field is 

either null or blank. 

 

Are not empty or 

blank 

Is Not Null 

And Not "" 

Returns records 

where the field has a 

non-blank, non-null 

value. 

 

Follow a value 

when sorted 

alphabetically 

>= "value" Returns records for 

all fields starting from 

the specified value 

and continuing to the 

end (based on 

alphabetical sorting 

order). 

Example: >= "Mexico" returns 

records for Mexico and all 

countries/regions that come after it 

alphabetically. 

Fall within a 

specific range of 

characters 

Like "[start-

char]-[end-

char]*" 

Returns records for 

all fields that start 

with characters 

between the specified 

range (inclusive). 

Example: Like "[A-D]*" returns 

records for countries/regions whose 

names start with the letters "A" 

through "D". 

Match one of 

two or more 

values 

"value1" Or 

"value2" Or 

... (list all values) 

Returns records that 

match any of the 

specified values. 

 

Contain one of 

the values in a 

list 

In("value1", 

"value2", ...) 

(list all values) 

Returns records that 

match any of the 

values in the list. 

 

Contain certain 

characters at a 

specific position 

Right([field 

name], length) 

= "character" 

Returns records 

where the specified 

character is at the 

specified position 

within the field value. 

Right([CountryRegion], 1) = "y" 

returns records for all 

countries/regions where the last 

letter is "y". Replace "length" with 

the actual character position (e.g., 1 

for the last character). 

Satisfy length 

requirements 

Len([field 

name]) 

operator value 

Returns records 

where the field length 

meets the specified 

condition. 

Replace "operator" with a 

comparison operator like >, <, >=, or 

<= and "value" with the desired 

length. 



Match a specific 

pattern 

Like "pattern" Returns records that 

match the specified 

pattern using 

wildcards. 

The question mark (?) represents a 

single character, and the 

underscore (_) represents a single 

character that cannot be a wildcard 

(*) 

 

CREATING A REPORT 

1. Choosing the Data Source: 

• Before creating the report, ensure you have a table or query containing the 

data you want to display. 

2. Creating the Report: 

• In the Navigation Pane,  select "Report" from the menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Switching to Design View: 

• By default, Access opens the report in Layout View. To add headers and 

pictures, you'll need to switch to Design View. 

• Click on the "Design" tab on the ribbon and then the "View" button in the 

"Layout" group. 

• This will switch you to Design View, where you can modify the report's layout. 

 

 

 

It instantly gives a 

result like this 



 

 

 

 

 

4. Adding a Report Header: 

• The Report Header section appears at the top of every page in the report. 

• To add a report header, double-click on the gray area above the Detail section 

(where your data will be displayed). 

• This activates the Report Header section. 

5. Inserting a Title and Picture: 

• In the Report Header section, you can insert a title by clicking in the desired 

location and typing the text. 

• To add a picture, go to the "Insert" tab and click on "Picture." 

• Browse to the location of your image file and select it. 

• You can resize and position the picture by dragging the corners or using the 

mouse while holding down the Shift key. 

 

 

 

 

 

 

 

 

 

 

6. Adding Page Headers and Footers: 

• Similar to the Report Header, you can create Page Headers and Footers that 

appear on every page (top and bottom, respectively). 

• Right-click on the gray area above or below the Detail section and choose 

"Page Header/Footer" from the menu. 

• You can add text, pictures, or page numbers to these sections. 

Click here once  

Then click here or anywhere you want to put 

a title once …then start typing. 

Click here once to 

add an image … 

Then click where you 

want to put the 

image. Once clicked, 

it will show a 

window where you 

will need to browse 

the image then 

navigate to and 

select the image you 

want 



7. Formatting and Grouping Data: 

• Use the tools in the "Design" tab to format your report, such as changing font 

styles, font sizes, and alignment. 

• You can also group your data by specific fields to organize the report further. 

This is done by dragging the desired field from the Field List pane onto the 

Group Header section. 

8. Saving and Previewing the Report: 

• Once you've finished designing your report, save it by clicking on the "File" tab 

and then "Save As." 

• To preview the report before printing, click on the "View" tab and then "Report 

View." This will show you how the final report will look. 

9. Printing the Report: 

• When you're ready to print the report, go to the "File" tab and click on "Print." 

• You can adjust printing settings like page orientation and margins before 

sending it to your printer. (As I mentioned above, you will need to use the 

snipping tool to copy only the important area and paste in Microsoft 

word)  

 

 

 

CREATING A FORM  

1. Selecting the Data Source: 

• Before creating a form, ensure you have a table or query containing the data 

you want to display and edit. 

2. Creating the Form: 

There are two main ways to create a form: 

• Form Wizard: This guided approach walks you through selecting fields, 

layouts, and options. 

• Design View: This offers more flexibility for customizing the form's 

appearance and functionality. 

 



 

 

 

 

 

3. Using the Form Wizard (Optional): 

• In the Navigation Pane, select "Form" from the menu. 

• Choose "Form Wizard" and follow the steps in the wizard. You can select the 

fields you want to include, choose a layout style, and customize some basic 

formatting options. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Here 

Click Here to 

select all the 

fields once .  

If the question doesn’t require any one 

or more of those fields then simply click 

the field you don’t want then when it 

highlights black, click that arrow to 

remove it from the selected fields 

Click Here  

Change the name of 

your form if necessary 

to do so  



 

 

 

 

 

 

 

 

 

 

 

 

 

• Once done…. (As I mentioned previously, you will need to use the 

snipping tool to copy only the important area and paste in the Microsoft 

word document continuing with all the questions) 

 

 

 

 

Creating and Editing a Presentation: CREATING POWERPOINT 

PRESENTATIONS 

Open Powerpoint 

 

 

 

 

 

 

 

 

 



 

 

 

CREATING A PRESENTATION 

 

  

  

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

ADDING A CHART 

Click Blank 
Click to add the title you’re 

assigned to add 

You can also change the feel by changing the colours and the 

font styles, size and whatever that makes it look cool and 

proffessional 

To add a slide: You can click any layout choice according to the 

need of the question 



 

 

 

 

 

 

  

 

 

  

 

 

 

 

 

 

 

 

 

 

 

Add the table then put fill it with the information you’re 

provided 

Something like this 
Specify the number of 

rows and columns 

ADDING A CHART 

Click on the bars 

You might need to adjust 

your choice of abrs 



 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

  

 

 

 

 

If you made a mistake in entering the data you can always change by right clicking the table 

the Click “Edit Data” 

As soon as you click the pichrt then 

click ok, this appears, edit the 

information to what your exam 

wants…after your done just click 

the X at the top left corner 

For example 

You can change the design of our chart 

here 



 Like so 

 

 

 

 

 

  

 

 

 

 

 

 

 
 


